LANCOM Support Knowledgebase Document No. 1710.1913.1422.AFRI - V2.20

Vulnerability in WPA2 (KRACK attack): Recommended actions for LANCOM devices


Description:
LANCOM is releasing the following security updates to resolve the WPA2 vulnerability:

Version
Date
LCOS 10.12 SU1
20.10.2017
LCOS 9.24 SU7
20.10.2017
LCOS 9.10 SU10
20.10.2017
LCOS 9.00 SU6
27.10.2017
LCOS 8.84 SU10
27.10.2017
LCOS 8.82 SU2
27.10.2017
LCOS 8.80 SU2
27.10.2017
LCOS 8.62 SU8
27.10.2017

Detailed information on implementing these updates is available in the release notes for the respective version: Download.

The following table lists all LANCOM WLAN devices with the recommended action for each relating to the WPA2 vulnerability KRACK attack.


Devices of the current LANCOM product range (date: October 2017):

Product
Recommended action
    Download firmware
LANCOM 883 VoIPUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM 1781VAWUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM 1783VAWUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM 1781AWUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM 1781EW+Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM 1780EW-4G+Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-151gnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-151EUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-320agn
(from HW release G)
Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM L-320agn (R2)Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-321agn
(from HW release G)
Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM L-321agn (R2)Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-322agn
(from HW release G)
Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM L-322agn (R2)Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-322EUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-330agnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-630acnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-822acnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-830acnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-830EUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-860Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-862Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-1302acnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-1310acnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-1700Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM LN-1702Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM IAP-821Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM IAP-821Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAP-821Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAP-822Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAP-830Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).



Older LANCOM devices:

Product
Recommended action
    Download firmware
LANCOM 1511When operated in the AP and client/station modes, this device type is not affected. For the point-to-point (P2P) mode, we recommend that you use an additional protection layer, e.g. IPSec. No further LCOS update are available for this device type.
LANCOM 1521When operated in the AP and client/station modes, this device type is not affected. For the point-to-point (P2P) mode, we recommend that you use an additional protection layer, e.g. IPSec. No further LCOS update are available for this device type.
LANCOM 1780EW-3GUpdate the LCOS operating system to version LCOS 9.24 SU7.
LANCOM 1781EWUpdate the LCOS operating system to version LCOS 9.24 SU7.
LANCOM 1780EW-4GUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM 1811When operated in the AP and client/station modes, this device type is not affected. For the point-to-point (P2P) mode, we recommend that you use an additional protection layer, e.g. IPSec. No further LCOS update are available for this device type.
LANCOM 1811nUpdate the LCOS operating system to version LCOS 9.00 SU6.
LANCOM 1821When operated in the AP and client/station modes, this device type is not affected. For the point-to-point (P2P) mode, we recommend that you use an additional protection layer, e.g. IPSec. No further LCOS update are available for this device type.
LANCOM 1821nUpdate the LCOS operating system to version LCOS 8.82 SU2.
LANCOM 1821+Update the LCOS operating system to version LCOS 8.84 SU10.
LANCOM 1823 VoIPUpdate the LCOS operating system to version LCOS 8.84 SU10.
LANCOM 3050When operated in the AP and client/station modes, this device type is not affected. For the point-to-point (P2P) mode, we recommend that you use an additional protection layer, e.g. IPSec. No further LCOS update are available for this device type.
LANCOM 3550When operated in the AP and client/station modes, this device type is not affected. For the point-to-point (P2P) mode, we recommend that you use an additional protection layer, e.g. IPSec. No further LCOS update are available for this device type.
LANCOM 3850 UMTSUpdate the LCOS operating system to version LCOS 9.00 SU6.
LANCOM C-54Update the LCOS operating system to version LCOS 8.84 SU10.
LANCOM IL-11The device type is not affected because WPA / WPA2 is not supported.
LANCOM IL-2The device type is not affected because WPA / WPA2 is not supported.
LANCOM L-11The device type is not affected because WPA / WPA2 is not supported.
LANCOM L-2The device type is not affected because WPA / WPA2 is not supported.
LANCOM L-54gUpdate the LCOS operating system to version LCOS 8.84 SU10.
LANCOM L-54agUpdate the LCOS operating system to version LCOS 8.84 SU10.
LANCOM L-54 dualUpdate the LCOS operating system to version LCOS 8.80 SU2.
LANCOM L-305agnUpdate the LCOS operating system to version LCOS 8.80 SU2.
LANCOM L-310agnUpdate the LCOS operating system to version LCOS 8.80 SU2.
LANCOM L-315agnUpdate the LCOS operating system to version LCOS 9.00 SU6.
LANCOM L-320agn
(before HW release G)
Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM L-321agn
(before HW release G)
Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM L-322agn
(before HW release G)
Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM L-451agnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-452agnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM L-460agnUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM IAP-54Update the LCOS operating system to version LCOS 8.62 SU8.
LANCOM IAP-321-3GUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM IAP-321Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM IAP-322Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAP-321Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAP-322Update the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAP-321-3GUpdate the LCOS operating system to version LCOS 10.12 SU1 (or higher).
LANCOM OAC-54-1Update the LCOS operating system to version LCOS 9.00 SU6.
LANCOM OAP-54-1Update the LCOS operating system to version LCOS 8.62 SU8.
LANCOM OAP-54Update the LCOS operating system to version LCOS 9.00 SU6.
LANCOM OAP-310Update the LCOS operating system to version LCOS 9.00 SU6.
LANCOM OAP-382Update the LCOS operating system to version LCOS 9.24 SU7.
LANCOM XACUpdate the LCOS operating system to version LCOS 9.00 SU6.
LANCOM XAPUpdate the LCOS operating system to version LCOS 8.80 SU2.

Catchwords: devices; fix; krack attack; wpa2
Please review this document! This document was helpful This document was not helpful